library not found for -lstdc++.6.0.9

 

部分项目依赖 libstdc++.6.0.9 的会在Xcode 10无法运行,

其原因是Xcode 10中将libstdc++.6.0.9库文件删除(Xcode10把libstdc++换成了libc++),原本功能迁移至其他库

将文件 libstdc++.6.0.9.tbd 文件点击下载

复制到目录下

 

真机环境

/Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/Developer/SDKs/iPhoneOS.sdk/usr/lib/ 

 

模拟器环境

/Applications/Xcode.app/Contents/Developer/Platforms/iPhoneSimulator.platform/Developer/SDKs/iPhoneSimulator.sdk/usr/lib/

即可解决

早起的年轻人 CSDN认证博客专家 移动开发 项目管理 Java
只要用心去做,每一件事情还是有可能成功的,当然成功是没有界限的,只不过是达到自己心里的那个目标,公众号:我的大前端生涯,一个爱喝茶的程序员,通常会搞搞SpringBoot 、Herbinate、Mybatiys、Android、iOS、Flutter、Vue、小程序等.
©️2020 CSDN 皮肤主题: 代码科技 设计师:Amelia_0503 返回首页